New Devices not appearing in Device Search

Incident Report for Memfault

Resolved

This incident has been resolved.
Posted May 27, 2026 - 20:02 UTC

Identified

We are aware of an issue preventing new devices from appearing in device search. We are currently implementing a fix for this and expect to restore functionality later today. No devices or data have been lost.
Posted May 27, 2026 - 13:30 UTC
This incident affected: API & Dashboard.