AWS Outage in us-east-1 causing service disruption

Incident Report for Memfault

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:41 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:05 UTC

Monitoring

An AWS operational issue in us-east-1 affected multiple services. Restoration of service is now underway and we are seeing traffic flow in again. We expect some ingestion backlogs and additional latency as everything returns to normal. We are monitoring and will provide updates as needed.
Posted Oct 20, 2025 - 09:54 UTC
This incident affected: API & Dashboard, Ingress, and OTA.